Senate Minority Leader McConnell’s statement on Obama admin’s latest Obamacare re-write

mitch_mcconnell

McConnell Statement on Latest Administration Effort to Manipulate Obamacare Coverage Requirements

‘By announcing a new delay in requiring that policies meet minimum coverage standards, the administration avoids a new round of health policy cancellations set to hit shortly before the November elections. What makes this latest delay so troubling is the fact that it was prompted not by the heartbreaking stories of millions of Americans but by the private pleadings of a handful of endangered Democrats.’

WASHINGTON, D.C. – U.S. Senate Republican Leader Mitch McConnell issued the following statement today regarding the administration’s latest attempt to manipulate Obamacare minimum coverage requirements in an effort to protect endangered Democrats:

 

“The Obama administration’s announcement today that it will continue to allow insurers to sell health care plans that don’t meet Obamacare minimum coverage requirements is not only another reminder of the President’s broken promise that you can keep your plan if you like it, but represents a desperate move to protect vulnerable Democrats in national elections later this year. By announcing a new delay in requiring that policies meet minimum coverage standards, the administration avoids a new round of health policy cancellations set to hit shortly before the November elections. What makes this latest delay so troubling is the fact that it was prompted not by the heartbreaking stories of millions of Americans but by the private pleadings of a handful of endangered Democrats. Americans have become increasingly aware of the fact Obamacare is broken beyond repair. The only ‘fix’ is full repeal followed by step-by-step, patient-centered reforms that drive down costs and that Americans actually want.”

 

####

Leave a Comment ()